Difference between revisions of "Template:Nexus EU-GDPR Login"

From Nexus Mods Wiki
Jump to: navigation, search
(Detail: update)
(Detail: update)
 
(2 intermediate revisions by the same user not shown)
Line 23: Line 23:
 
background-color:#fff5f5;padding:3px;
 
background-color:#fff5f5;padding:3px;
 
word-wrap: break-word;      /* Internet Explorer 5.5+ */
 
word-wrap: break-word;      /* Internet Explorer 5.5+ */
">As of 08 May 2018, the Nexus has changed some site security to come into compliance with the new "European Union General Data Protection Regulation" (EU GDPR) rules.  This breaks older versions of NMM and is usually reported as being "blocked by the Windows firewall" or causing a "script" or "W3C XML Schema" error installing mods.  You will need to update it from [http://github.com/Nexus-Mods/Nexus-Mod-Manager/releases/ NMM on GitHub] or this [http://www.nexusmods.com/site/mods/4/? Nexus NMM download page].  Check the version numbers between those sites and use the latest (v0.65.4 at this time).  Please see [http://www.nexusmods.com/newvegas/news/13481 this Nexus site news article] for details.
+
">As of 08 May 2018, the Nexus has changed some site security to come into compliance with the new "European Union General Data Protection Regulation" (EU GDPR) rules.  This breaks older versions of NMM and other tools using the older unsecured API.  It is usually reported as being "blocked by the Windows firewall" or causing a "script" or "W3C XML Schema" error installing mods.  You will need to update it from [http://github.com/Nexus-Mods/Nexus-Mod-Manager/releases/ NMM on GitHub] or this [http://www.nexusmods.com/site/mods/4/? Nexus NMM download page].  Check the version numbers between those sites and use the latest (v0.65.4 at this time).  Please see [http://www.nexusmods.com/newvegas/news/13481 this Nexus site news article] for details.
  
A Working "unofficial" fix (confirmed) to login to Nexus with MO (v1) or older NMM versions without updating is available in this Reddit thread:
+
As of 13 May 2019 all "workarounds" that depend upon continued use of the old API will no longer function.  That API has been removed, as previously announced more than two years previously.  This includes but is not limited to:
[http://www.reddit.com/r/skyrimmods/comments/8ibbu4/classic_login_fix_for_mo1nmm_no_update_needed/ Classic Login fix for MO1/NMM].<br> Note: this "fix" reverts to using the older, unsecure API at a fixed, no longer used IP address (instead of the address returned using DNS), and thus negates the EU GDPR standard.  It could get shutdown without warning 25 May or after as that is the EU deadline for compliance and Nexus is hosted in the United KingdomUse at your own risk.
+
* Nexus Mod Manager v0.65.11 and lower
 +
* Mod Organiser 2 v2.1 and lower
 +
* Mod Organizer 1
 +
This only affects the ability of these tools to login and automate the download from the Nexus siteThey continue to perform their other functions.
  
 
Some people are finding that even after updating NMM to v0.65.4 they still get a "script exception" message when installing some mods (such as UIO and MCM).  This seems to be resolved by this suggestion from user '''ElysianMod''':
 
Some people are finding that even after updating NMM to v0.65.4 they still get a "script exception" message when installing some mods (such as UIO and MCM).  This seems to be resolved by this suggestion from user '''ElysianMod''':
Line 58: Line 61:
 
* [[Fallout_NV_Mod_Conflict_Troubleshooting|Fallout NV Mod Conflict Troubleshooting]].
 
* [[Fallout_NV_Mod_Conflict_Troubleshooting|Fallout NV Mod Conflict Troubleshooting]].
  
[[Category:New_Vegas]]
+
[[Category:New_Vegas]] [[Category:New_Vegas_Templates]]

Latest revision as of 14:43, 14 May 2019


Overview

This template is so it may be included in several instances in the articles

Programs and Tools

  • A plain text editor like Windows Notepad.

Detail


References

Nexus wiki articles referred to by this article:

Nexus wiki articles that refer to this article: