KCD Naming convention
While dealing with clothing item files you will get in touch with strange names like this " s1_p2_l1_v0 "
Rather than using descriptive names which could be very very long we decided to compress the name into shortest lenght as possible to keep things clear and easy to read.
However it does not sound like it, it is very easy to find desired file very quickly.
- s1_ prefix stands for skeleton - 1 = male, 2 = female, 3 = child, sh = horse
- p2_ prefix stands for body part - 1 = head, 2 = body, 3 = legs, 4 = boots
- l1_ prefix stands for layer - 1 = liner/gambeson layer, 2 = chainmail, 3= plate armor, 4 = coat/waffenrock
- v0 stands for version - v0 is the number used for Base geometry with blendShapes, v1...2.... means its Unique geometry (mostly seen in plate armor items)
But it can get even worse by adding lod postfix s1_p2_l1_v0_lod1. Currently we have 3 meshes considered as lods.
- _lod1 cca 50% polycount of the original mesh - currently does not support blendShapes
- _lod2 cca 25% polycount of the original mesh- currently does not support blendShapes
- _lodC - this mesh is is optimized original mesh for consoles with blendShapes supported
Its not everything s1_p2_l1_v0_tx013_spec. This is name of texture file.
- _tx013 - is texture/material variation - this was meant to correspond with variation blendShape number, but we've desynchronized this by adding another variation to the texture, which is using same blandShape which than should look like _tx013v01 ..v02 etc
so if you are creating new item from Base geometry with blendshapes use next number after the highest one. (In this case new material or texture will be _tx014)
- _spec - specular map. See Cryengine documentation for other texture types and their postfixies
File name in words
Skeleton _ BodyPart _ Layer _ GeometryType _ MaterialNumber _ TextureType