Difference between revisions of "Creating an armour for Fallout 4. Part 1"

From Nexus Mods Wiki
Jump to: navigation, search
m
m (Required tools)
Line 10: Line 10:
 
** You can use the old and stable Blender version 2.49, and follow the instructions given here: [[Installation_of_Blender|Installation of Blender]] to install everything you need.
 
** You can use the old and stable Blender version 2.49, and follow the instructions given here: [[Installation_of_Blender|Installation of Blender]] to install everything you need.
 
** If you want to use a newer version of Blender, don't use version 2.76b, as the copy weights between meshes doesn't work properly. Install version 2.75 instead. Then you should install the [http://niftools.sourceforge.net/forum/viewtopic.php?f=13&t=5823 Blender Nif Plugin 2.6.0a0.dev4]. Take into account that this is not a official release but that it is still under development.
 
** If you want to use a newer version of Blender, don't use version 2.76b, as the copy weights between meshes doesn't work properly. Install version 2.75 instead. Then you should install the [http://niftools.sourceforge.net/forum/viewtopic.php?f=13&t=5823 Blender Nif Plugin 2.6.0a0.dev4]. Take into account that this is not a official release but that it is still under development.
* [http://www.gimp.org/ GIMP]: For painting textures. You can follow the instructions given here: [[Installation_of_GIMP|Installation of GIMP] to install everything you need.
+
* [http://www.gimp.org/ GIMP]: For painting textures. You can follow the instructions given here: [[Installation_of_GIMP|Installation of GIMP]] to install everything you need.
 
* [http://www.niftools.org/ Nifskope]: Used for fine tunning the meshes for using them inside the game.
 
* [http://www.niftools.org/ Nifskope]: Used for fine tunning the meshes for using them inside the game.
 
** [https://github.com/jonwd7/nifskope/releases/tag/v2.0.dev4 NifSkope 2.0 Pre-Alpha 4] is the first version of NifSkope that supports the FO4 format. Take into account that it is not a official release but that it is stilll under development.
 
** [https://github.com/jonwd7/nifskope/releases/tag/v2.0.dev4 NifSkope 2.0 Pre-Alpha 4] is the first version of NifSkope that supports the FO4 format. Take into account that it is not a official release but that it is stilll under development.
* [http://www.autodesk.com/education/free-software/3ds-max]: 3ds Max, only for importing and exporting meshes to the FO4 format. If you are a student you can get your free version of Max directly from the homepage. And [https://github.com/figment/max_nif_plugin/releases/tag/3.8.0]: 3ds Max Nif plugin that supports Fallout 4 nif format.
+
* [http://www.autodesk.com/education/free-software/3ds-max 3ds Max]: Only for importing and exporting meshes to the FO4 format. If you are a student you can get your free version of Max directly from the homepage. And [https://github.com/figment/max_nif_plugin/releases/tag/3.8.0 3ds Max Nif plugin]: that supports Fallout 4 nif format.
 
 
  
 
==References==
 
==References==

Revision as of 08:39, 28 March 2016

Overview

This tutorial shows all the main steps you need to follow to create an armour or an outfit from scratch for Fallout 4. If you only want to change the textures of an existing piece of clothing or change its properties and bonus, just skip the first part of the tutorial. If you want to adapt existing armours or outfits to other bodies you will have to follow the steps explained here, except that you won't have to create the mesh (but you may probably have to adapt it to the new body), the textures or the UV maps.

Currently the tools used for modelling are not completely adapted for Fallout 4, there are some steps that require some manual adjustments. Bethesda hasn't either released the GECK for this game, yet, so some other tools made by modders are required at this stage. This will surely change in the future months and this tutorial will be updated when required.

Required tools

  • Blender: Main tool used for creating the meshes, assigning weights and creating the UV maps.
    • You can use the old and stable Blender version 2.49, and follow the instructions given here: Installation of Blender to install everything you need.
    • If you want to use a newer version of Blender, don't use version 2.76b, as the copy weights between meshes doesn't work properly. Install version 2.75 instead. Then you should install the Blender Nif Plugin 2.6.0a0.dev4. Take into account that this is not a official release but that it is still under development.
  • GIMP: For painting textures. You can follow the instructions given here: Installation of GIMP to install everything you need.
  • Nifskope: Used for fine tunning the meshes for using them inside the game.
    • NifSkope 2.0 Pre-Alpha 4 is the first version of NifSkope that supports the FO4 format. Take into account that it is not a official release but that it is stilll under development.
  • 3ds Max: Only for importing and exporting meshes to the FO4 format. If you are a student you can get your free version of Max directly from the homepage. And 3ds Max Nif plugin: that supports Fallout 4 nif format.

References