Oblivion custom in-game map

From Nexus Wiki

Jump to: navigation, search

Contents

Overview

This article explains one method on how to create a working world map for your worldspace in Oblivion. In this tutorial I assume you know your way around the CS, and how to use your chosen image editing program. The method used in the tutorial creates what I've come to call a 'satellite' image of your entire worldspace (or chosen cells within the worldspace) and it shows everything except for trees and actors. That includes rocks, buildings, and even Trigger boxes or Collision boxes. There's a few things that needs to be done before you can make a convincing in-game map.

Tools needed:

ICY Hexeditor

Photoshop or similar program (this tutorial will cover Photoshop use)

Oblivion Construction Set

Photoshop DDS plugin


Construction Set Step I

The first step is to remove everything you DON'T want to show. This especially means remove all Collision boxes or Trigger boxes you have used. Don't worry, we won't need to save the esp to make or map until much later, at which point it can simply be reloaded in the CS. Also, generating a local map does NOT show water, so it is highly recommended that you texture the shore of your land different than the underwater parts, because we will be creating our own water using selections and colorizing it.

The second step needed is to create local maps. This is done by opening our esp in the CS and going to World and then all the way down to Create Local Map. In the dropdown, select the worldspace and then UNCHECK all cells and enter the cell coordinate for the upper left corner and bottom right corner of our map. This will create a 'grid' and every cell inside of the grid will be saved as a separate image. The images are saved in Data\Textures\Maps. When you're setting the NW (Upper Left) and SE (Lower Right) corners of your 'map' it's highly recommended you use cells that are water, also, write down the NW cell coordinate, we'll need it later. Because the Oblivion map menu has a 'border' part of our map will be cut off so we want to have some water space to work with so our land isn't cut off in-game.

Now that we have our local map created we need to figure out how large to make our canvas in Photoshop for our map. Each 'cell' generated by the Local Mapping in the CS is 256x256 pixels, but there's some overlapping (this will be explained in a moment), so we can't use 256. The actual size we will be using is 241x241. Now, to figure out the size we need to figure out two things. How wide our map is along the Y coordinate and how high our map is along the X coordinate.

To do this, browse to the folder with the map images. Every image follows this format:

WorldSpaceName.XX.YY.dds

Photoshop

NOTE: This is only for the CANVAS size while building our map. Before we port it into the CS and save it as a .DDS the map MUST be 2048x2048 or SMALLER.

If the cells we used are -4 to 01 along the X axis then we have SIX numbers. (-4, -3, -2, -1, 00 and 01.) The same method is used for the Y axis. Now, to figure out how many pixels we need for the Height and Width we simply take our X axis cells (6) and multiply that by 241which gives us 1446.

Another method you could do is much simpler. Simply use an overly large canvas size such as 5000 or 10000 pixels. I actually used the second method in my own world map because I was too lazy to figure out the exact number of pixels needed.

Once you've finished your chosen method it's time to start building our map. If you remember I mentioned there was some overlapping used in the local map, and we need 241 of the 256 pixels used. Here's how the cells overlap: There is a 14 pixel overlap with the cell ABOVE, 1 pixel overlap with the cell BELOW, 14 with the cell to the RIGHT and 0 with the cell to the LEFT.

Following this tutorial, however, will fix the overlapping without having to crop each image separately.

Before we actually start building the map there is one more thing we need to set up, and that's Snapping. In photoshop, to turn on Snap go to View-> Snap or hit Alt+Ctrl+;

Once snap is turned on, open our NW cell and place it on our canvas, then select the Move tool and drag it to the upper left corner of our canvas. DO NOT PLACE THE SECOND CELL YET! Now we need to fix the overlap. To do this, with the move tool still selected, hit the UP arrow key 15 times to nudge the layer 15 pixels (this takes care of the 14 top and 1 bottom)

WARNING!!!! When using the nudge you MUST be at 100% zoom! Nudging is relative to your zoom, so if you zoom out to 50% then you're actually moving the layer TWO pixels at a time! So make sure you're at 100% zoom or our map won't turn out right! WARNING!!!!

Now we want to place the second cell. If our NW cell was coordinate -4,-1, then the cell below it will be -4,00. Because snapping is enabled this will allow us to easily line up the cells with each other. Once the cell is lined up, hit the up arrow key (again, with the move tool) 15 times. Continue to do this until we have our first column completed.

The second column is a bit different, but it'll also go MUCH quicker than before. When we place the first cell for the second row we need to nudge it UP 15 times, but also to the LEFT 14 times. Now, the rest of the column will go much quicker because we turned on Snapping. All you simply need to do now is place the next cell in the column. Because we turned on snapping, you can actually make the cell snap into position. With the move tool, drag the cell up SLOWLY until it 'snaps' into place. Then, drag it to the LEFT until it snaps into place. Continue to do this for the rest of the column.

The third (and the rest) column is exactly like the second. When placing the FIRST cell in a column you need to manually nudge it 15 times up, and 14 times to the left, and then you can use snapping to place the rest of your cells.


After all cells are in position, flatten the entire image by right clicking in the layer palette and clicking on Flatten Image. It's best to work with a perfectly square map, and the size MUST 2048x2048 or SMALLER and a multiple of FOUR (512, 1024, 2048 etc). Choose the image size closest (but LARGER) to the size of your map. It doesn't matter if you leave some white in our new canvas after placing your map, it's just a requirement that our map be square and a multiple of four. Position our map so the upper left corner of our map is flush with the upper left corner of our canvas (snapping will take care of this!)

Now that we have our map built, and the proper canvas size, we need to save the map in the proper location. Save it as a .dds in Data\Textures\map\yourmod. The filename doesn't matter, but it's best to use WorldSpaceNameMap. Now that we have our map complete we need to get it in game.

Construction Set Step II

Open the CS back up, and then go to World->World Spaces. In the new menu find your worldspace in the list and left click it. In the Map Data menu, click on Add Image File, and then browse to your newly made map. Set the usable dimensions to the size of our map NOT the size of our canvas!

Note: The usable dimensions can be any size, and don't have to be a perfect square.

Then, for the Cell Coordinates set the NW and SE coordinates to the SAME ones you used during the Local Map generation. After that's done, click okay and save your mod. However, the map won't appear in-game yet (due to a rather annoying, but easily fixed bug in the CS).

ICY Hex Editor

This is where our Hex Editor comes in. If you don't know anything about Hex editing don't worry, this is a very simple process. Launch ICY Hexplorer and then click on File->Open and open the .ESP. You MUST open the ESP!! If the text is impossibly small and you can't read it go to View->Options and then change the font to something you can read.

Next, click on the Replace button (The button with the A and B) and in the FIND text field type in:

menus\map\world\MapName.dds

Hit find. The hex editor should highlight a string of numbers and letters that looks like this:

6D656E75735C6D61705C776F726C645C

If so, then it found the right one. If not, check spelling and make sure you use \ and NOT / in the filepath. If it did, simply retype the file path we used in the Find field, but instead change the m in menu to a capital m, so it looks like:

Menus\map\world\

Once you do that, simply go to save and we're all set! Launch Oblivion and then travel to your worldspace to see your new working map!

Personal tools